Welcome to EnviroDIY, a community for do-it-yourself environmental science and monitoring. EnviroDIY is part of WikiWatershed, a web toolkit designed to help citizens, conservation practitioners, municipal decision-makers, researchers, educators, and students advance knowledge and stewardship of fresh water. New to EnviroDIY? Start here

Mayfly with Xbee MTech mDot LoRa module

Home Forums Mayfly Data Logger Mayfly with Xbee MTech mDot LoRa module

Viewing 2 reply threads
  • Author
    Posts
    • #15637
      Dale Drummond
      Participant

      Hello,

      I’ve been working on getting a Mayfly working with an MTech mDot LoRa module. I cannot get any readable text back from the module even after trying all the different baud rates. Does anyone have this module working with their Mayfly? If so, can you share your sketch on the pin and board setup? I think I have everything configured correctly, but I can’t figure out why I am not getting good output from the Serial1 read. Below is the text I get.

      I have attached a copy of my sketch. Any pointers are appreciated.

      Dale

    • #15639
      Shannon Hicks
      Moderator

      I’m not familiar with that module, but the specs say that its default baud rate is 115200, so you should set your “modemBaud” rate in the sketch to match that, so something like:

      Was that the value you changed in your sketch?  Because it’s set at 9600 in the example you attached.  Have you successfully communicated with the LoRa module by itself, outside of the Mayfly, by using just a basic bee carrier board?

    • #15643
      Dale Drummond
      Participant

      Hi Shannon,

      Thanks for the reply. I have tried every baud rate for the modemBaud setting. I just tried again with 115200. I get a slightly different response but unfortunately, it’s still not readable.

      I don’t have a basic bee carrier card. I will order one and see what the response is from the module there.

      Thanks again for the reply!

      Dale

Viewing 2 reply threads
  • You must be logged in to reply to this topic.