Welcome to EnviroDIY, a community for do-it-yourself environmental science and monitoring. EnviroDIY is part of WikiWatershed, a web toolkit designed to help citizens, conservation practitioners, municipal decision-makers, researchers, educators, and students advance knowledge and stewardship of fresh water. New to EnviroDIY? Start here

Mayfly USB Connection Problems

Home Forums Mayfly Data Logger Mayfly USB Connection Problems

This topic contains 10 replies, has 5 voices, and was last updated by  Brett Melbourne 3 weeks, 3 days ago.

  • Author
    Posts
  • #1512

    John Smutny
    Participant

    While experimenting with the Mayfly Data logger to upload different Arduino programs from my computer, I came across an issue with the communications between the board and the USB port of my computer. Repeatedly, The computer couldn’t recognize the board and gave me an error message at the bottom right hand corner of my screen saying “USB Device Not Recognized”. However, when the computer does recognize the board, simply touching the ON/OFF switch (while the switch is ON) interrupts the USB connect while retaining power to the board. The only solution I have found is to turn the board off while holding the RESET button and then turn the board ON while letting go of the RESET button. I’m curious if anyone has had this issue or has their own solutions. Thanks

    PROBLEM: ON/OFF switch (while in the ON position) can interrupt USB communications with my computer’s USB port. USB works with my flash drive and other arduino boards, just not the Mayfly

  • #1514

    Shannon Hicks
    Keymaster

    I’m not aware of any other issues with the power switch or USB connectivity. What operating system are you using? And did you buy the Starter Kit that comes with it’s own microUSB cable, or are you using your own cable? I’ve had connection issues with microUSB jack/cable combinations on other devices, so maybe try a different cable and see if that helps. Do you have an FTDI cable or adapter board that you could use to power and program the Mayfly to see if touching the power switch has the same effect?

    Another thing to troubleshoot whether it’s communication or power related would be to put a sketch on the board that lights both LEDs constantly, then disconnect the USB or FTDI cable, and plug in a battery to the LiPo jack. Then you can turn the switch on and keep an eye on the LEDs while touching the switch to see if perhaps there’s a loose connection in the switch.

  • #1518

    John Smutny
    Participant

    Currently my computer is running on Windows 8, 32-bit, and i am connecting the Board using the provided USB cable from the starter kit, and 3 other cords still have the same problem. But, I haven’t tried programming the board using the FTDI port yet and can test that when I gather the equipment.

    In regards to testing whether the switch removes power, using an external power supply with the pre-loaded flashing RED and GREEN LED program, tapping the switch (which causes the computer’s lack of recognition) does not effect the power supplied to the board. When I moved the loose switch around, while still in the ON position, the LED’s stayed ON. However, when I re-plugged the board into my computer, the board was no longer recognized.

    So, I don’t think this is so much a power issue, but my board’s switch some how is interfering with the USB connection with the board’s respective Drivers.
    Thank you for your help

  • #1530

    Shannon Hicks
    Keymaster

    The power switch on the Mayfly is a DPDT switch that has 2 functions. One pole switches the power input line to the main processor power rail, and the other other pole switches the power supplied to the FT232RL USB chip. So if there’s a defect in the switch mechanism on only one of the poles, it’s possible that the Mayfly will still power up and perform normally but the power for the USB converter could be intermittent. If you’re continuing to have problems with the switch, I’ll send you an email about how to resolve this.

  • #1531

    John Smutny
    Participant

    That sounds good, thank you for all of your help

  • #1558

    JimMoore
    Participant

    I received my starter kit a few days ago and could not connect to computer (surfacw-win 10) although my system worked fine with an arduino uno on another project.

    The cable that came with the kit was apparently defective because the system worked fine when I used another usb/microUSB cable I had. The defective cable supplied power but no serial comm

    Has anybody else had similiar problems with the supplied cable? If so, may be a quality problem with the supplier of that cable.

  • #1561

    Shannon Hicks
    Keymaster

    Thanks for the information JimMoore. I’ve personally used several dozen of the microUSB cables from that same shipment and haven’t had an issue with any of them, but we’ll make a note of it for future orders. I checked out the board that JohnSmutny had the issue with and it was indeed a bad mechanical contact inside the slide switch that caused the intermittent problem, but only on the pole that controls power to the FTDI circuitry.

  • #1564

    Breeves23
    Participant

    I am having problems accessing the Mayfly Data Logger in Windows 10. When plugged in, it is not recognized, nor can Windows find a driver. I do have the Arduino IDE installed, as well as the board files for the Data Logger. I tried downloading the basic FTDI driver files from FTDIchip.org, however when opening the serial port only gibberish is displayed, and I still cannot write a sketch. Any place I can find the correct drivers?

  • #1565

    Breeves23
    Participant

    As an update, I am getting this same problem on a Windows 7 machine, and 2 different Linux machines. Under the devices, it is listed as unknown, and the auto search is not finding the driver. When I try to connect or upload a sketch, I get this error: avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x2e

  • #1566

    Shannon Hicks
    Keymaster

    If Windows doesn’t find the drivers automatically, you’ll need to install them manually. I just installed the drivers on a dozen new Window 7 machines and WindowsUpdate was able to find the correct driver each time. The FTDIchip.org site has instructions for how to do that. Note that there are 2 different drivers that need to be installed: one is the FTDI drivers, and the other is the virtual com port (VCP). If the installation failed or didn’t go properly, the FTDI website has some instructions for how to update the drivers manually. If you check DeviceManager, do you see the virtual com port listed or any warnings under the ComPort or USB sections?

    Another alternative is if you already have an FTDI device, like the Adafruit FTDI-Friend, the Sparkfun FTDI Breakout, or a cable with built-in FTDI, and you’ve used it with other boards, then just use that to program the Mayfly via the FTDI header.

  • #12915

    Brett Melbourne
    Participant

    I found that I had to manually install the Windows 7 device drivers since they did not automatically install and Windows could not find drivers by itself. The instructions on the FTDI website are not entirely clear, so here are some additional notes.
    * Follow Windows 7 Installation Guide from FTDI website
    * Download both the D2XX driver and VCP driver (links are given in the installation guide), choosing the drivers appropriate to your computer’s CPU (e.g. a new computer is likely 64 bit, whereas if you are using an older laptop you might need the 32 bit x86 driver)
    * The D2XX and VCP drivers confusingly have the same name, so save them into separate empty folders called, say, D2XX and VCP so you can keep track of which is which
    * They need to be manually unzipped after downloading
    * The first driver that is being installed in the install guide instructions is the D2XX driver
    * From Device Manager, right click the device name. The Mayfly will come up under “Other devices” and be called something like “Unknown device” or “FT232R USB UART”. If it is not clear which device is the Mayfly, unplug it and watch to see which device is added when you plug it back in.
    * Select *Update driver software*
    * Select *Browse my computer …* – browse to and select the D2XX driver folder that you downloaded and is now unzipped (e.g. “CDM v2.12.28 WHQL Certified”)
    * After installing there should be a “success” message from the installer but there may also be a separate Windows tray notification saying “failed”. This appears to be normal (the failed message appears to be indicating that a COM driver is not yet installed).
    * The second installation is the VCP driver, which is the COM driver.
    * Basically, repeat the same steps as the first installation but this time choose the VCP driver
    * After installation the mayfly should show up in Device Manager as “USB Serial Port (COMX)”, where X is the COM number assigned to the device.

You must be logged in to reply to this topic.