Welcome to EnviroDIY, a community for do-it-yourself environmental science and monitoring. EnviroDIY is part of WikiWatershed, a web toolkit designed to help citizens, conservation practitioners, municipal decision-makers, researchers, educators, and students advance knowledge and stewardship of fresh water. New to EnviroDIY? Start here

Major Set Back-Need Help!

Home Forums Mayfly Data Logger Major Set Back-Need Help!

Viewing 6 reply threads
  • Author
    Posts
    • #15287
      Cheryl Nolan
      Participant

      I was just attempting to run one of the last sketches after having the entire unit (including the sensor and cellular boards and antenna) assembled, I was following along with the two workshop videos and found out I was missing a line of code or a file in the library, after copying and pasting the “Token UUID List” when I put my glasses down on the desk and touched the corner of the cellular antenna (the black adhesive-backed portion) and I heard the sound of the usb connecting (or disconnecting). I immediately picked up my glasses and heard it again. Now I can’t get anything to work. I don’t get anything when I download and run ‘temperature’ or ‘now’ programs. Did I just blow out all of my parts? I tried starting over with the downloading of the sketches and running the Serial Monitor, again no luck. I tried deleting the libraries and the Arduino program and starting over from scratch and now when I try to go through and make changes in the “preferences” step and attempt to install the EnviroDIY ATmega Boards, I get an error message “CRC doesn’t match, file is corrupt. It may be a temporary problem please try later.” How bad is it?:-/ Thanks

      FYI copied from error message window:
      Error downloading http://downloads.arduino.cc/tools/avrdude-6.0.1-arduino5-i686-mingw32.zip
      java.lang.RuntimeException: java.lang.Exception: Error downloading http://downloads.arduino.cc/tools/avrdude-6.0.1-arduino5-i686-mingw32.zip
      at cc.arduino.contributions.packages.ui.ContributionManagerUI.lambda$onInstallPressed$2(ContributionManagerUI.java:175)
      at java.lang.Thread.run(Thread.java:748)
      Caused by: java.lang.Exception: Error downloading http://downloads.arduino.cc/tools/avrdude-6.0.1-arduino5-i686-mingw32.zip
      at cc.arduino.contributions.DownloadableContributionsDownloader.download(DownloadableContributionsDownloader.java:149)
      at cc.arduino.contributions.DownloadableContributionsDownloader.download(DownloadableContributionsDownloader.java:83)
      at cc.arduino.contributions.DownloadableContributionsDownloader.download(DownloadableContributionsDownloader.java:60)
      at cc.arduino.contributions.packages.ContributionInstaller.install(ContributionInstaller.java:113)
      at cc.arduino.contributions.packages.ui.ContributionManagerUI.lambda$onInstallPressed$2(ContributionManagerUI.java:172)
      … 1 more
      Caused by: java.net.SocketException: Connection reset
      at java.net.SocketInputStream.read(SocketInputStream.java:210)
      at java.net.SocketInputStream.read(SocketInputStream.java:141)
      at java.io.BufferedInputStream.fill(BufferedInputStream.java:246)
      at java.io.BufferedInputStream.read1(BufferedInputStream.java:286)
      at java.io.BufferedInputStream.read(BufferedInputStream.java:345)
      at sun.net.www.MeteredStream.read(MeteredStream.java:134)
      at java.io.FilterInputStream.read(FilterInputStream.java:133)
      at sun.net.www.protocol.http.HttpURLConnection$HttpInputStream.read(HttpURLConnection.java:3444)
      at sun.net.www.protocol.http.HttpURLConnection$HttpInputStream.read(HttpURLConnection.java:3437)
      at cc.arduino.utils.network.FileDownloader.readStreamCopyTo(FileDownloader.java:268)
      at cc.arduino.utils.network.FileDownloader.openConnectionAndFillTheFile(FileDownloader.java:247)
      at cc.arduino.utils.network.FileDownloader.downloadFile(FileDownloader.java:182)
      at cc.arduino.utils.network.FileDownloader.download(FileDownloader.java:129)
      at cc.arduino.contributions.DownloadableContributionsDownloader.download(DownloadableContributionsDownloader.java:147)
      … 5 more

    • #15293
      fisherba
      Participant

      Try uploading a basic blink sketch using the Arduino IDE. I’m not sure from your description if the board even could be fried from what you did, but going back to something really basic would test this.

       

      • #15296
        Cheryl Nolan
        Participant

        Is this what you’re looking for? I got an error on that too and I don’t have the board connected to the computer yet. I was just trying to do the first steps in the Arduino program.

        Copied from error message:
        Arduino: 1.8.12 (Windows 10), Board: “Arduino Uno”

        Sketch uses 924 bytes (2%) of program storage space. Maximum is 32256 bytes.
        Global variables use 9 bytes (0%) of dynamic memory, leaving 2039 bytes for local variables. Maximum is 2048 bytes.
        Serial port not selected.

        This report would have more information with
        “Show verbose output during compilation”
        option enabled in File -> Preferences.

    • #15298
      fisherba
      Participant

      Are you working through a tutorial to learn how to do this? Here’s a link to some tutorials. https://www.envirodiy.org/mayfly/software/

      If you are just getting started with Arduino, I recommend starting in a generalized Arduino tutorial (not monitoring focused): https://learn.adafruit.com/series/ladyadas-learn-arduino. Here are directions through that Lada Ada tutorial with parallel information on the Mayfly: https://envirodiy.github.io/LearnEnviroDIY/01-ArduinoBasics/index.html

       

      • #15299
        Cheryl Nolan
        Participant

        Thanks, I was more than 3/4 of the way through the two 3-hour workshops that Shannon Hicks recorded and had all of the parts connected and all but the Interfacing With Monitor My Watershed and the Final Steps left to go when this happened. I had about 50 minutes of the 6 hour workshop to go. Everything was connected and working fine until I found I was missing one line of code and I put my glasses down on the desk and touched the corner of the antenna.

    • #15301
      Sara Damiano
      Moderator

      I would say the sound of the disconnect/reconnect isn’t a good sign, but touching the black part of the antenna shouldn’t have caused anything.  If the board shifted onto something metal (aluminum phone or laptop case or such) that might have connected pins oddly on the back it might have caused a jolt in the power on the USB which can sometimes cause windows to block that USB port until the next restart.  It definitely is possible to completely fry a Mayfly but when I’ve done it it’s been doing something a bit more foolish than just putting it on top of something metal.  If Windows blocked the USB port due to a surge, you must restart your computer and then it should be unblocked.

      I don’t know anything about the Java errors you posted in the first post.  That sounds like an error with the Arduino IDE itself not with your code.  I’d suggest restarting your computer for that, too.

      In the last post where you tried the blink sketch, it said the serial port was not selected and it compiled for the UNO.  You need to set the board to “EnviroDIY Mayfly 1284p” by using the “Board” option in the tools menu.  You also need to set the port to COM# of whatever Windows assigned it when it first connected.  If you did cause a surge on the USB and Windows shut it down, then you won’t see any options possible for the port until you’ve restarted.  If you still don’t see anything after restarting and Windows is making the “connected” and “disconnected” sounds when you unplug and re-plug the Mayfly to the USB there might be a problem with your FTDI drivers.

    • #15315
      Cheryl Nolan
      Participant

      I have the Com Port coming up now but when I try to run the board temp or now sketches I get an error message “Invalid version ‘0.28.01’ for library in: C:\Users\cnolan\Documents\Arduino\libraries\EnviroDIY_ModulatSensors” and the red light does not blink alternately with the green. I only get a blinking green light.

      This is what I get when I copy the error message:

      Arduino: 1.8.12 (Windows 10), Board: “EnviroDIY Mayfly 1284p”

      In file included from C:\Users\cnolan\Documents\Arduino\libraries\Tally_Library\src\Tally_I2C.h:25:0,

      from C:\Users\cnolan\Documents\Arduino\libraries\Tally_Library\src\Tally_I2C.cpp:21:

      C:\Program Files (x86)\Arduino\hardware\arduino\avr\libraries\Wire\src/Wire.h: In member function ‘uint8_t Tally_I2C::ReadByte(uint8_t, uint8_t)’:

      C:\Program Files (x86)\Arduino\hardware\arduino\avr\libraries\Wire\src/Wire.h:64:13: note: candidate 1: uint8_t TwoWire::requestFrom(int, int)

      uint8_t requestFrom(int, int);

      ^~~~~~~~~~~

      C:\Program Files (x86)\Arduino\hardware\arduino\avr\libraries\Wire\src/Wire.h:61:13: note: candidate 2: uint8_t TwoWire::requestFrom(uint8_t, uint8_t)

      uint8_t requestFrom(uint8_t, uint8_t);

      ^~~~~~~~~~~

      Sketch uses 69226 bytes (53%) of program storage space. Maximum is 130048 bytes.
      Global variables use 4659 bytes of dynamic memory.
      avrdude: ser_open(): can’t open device “\\.\COM3”: The system cannot find the file specified.

      Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.
      Invalid version ‘0.28.01’ for library in: C:\Users\cnolan\Documents\Arduino\libraries\EnviroDIY_ModularSensors
      Invalid version ‘0.28.01’ for library in: C:\Users\cnolan\Documents\Arduino\libraries\EnviroDIY_ModularSensors

      This report would have more information with
      “Show verbose output during compilation”
      option enabled in File -> Preferences.

    • #15323
      Sara Damiano
      Moderator

      Woops.  The invalid version number was my fault; I screwed up the semantic versioning.  I released a new version yesterday which is identical except for the version number which is now a valid 0.28.3.

      But  that isn’t actually your problem.  The invalid version number and the stuff about “requestFrom…” are just warnings.  It compiled anyway.  The real problem is that it didn’t find your Mayfly at your selected COM3.  Are you sure the Mayfly is actually connected, powered on, and enumerated as COM3?  Sometimes after a reset Windows will decide that the same Mayfly is a new device and will assign it a new serial port with a higher number.

    • #15402
      Cheryl Nolan
      Participant

      Just wanted to let the folks at Stroud know that I did finally get the Mayfly up and running and I was getting the data sent directly to the Monitor My Watershed site. Thank you all for all of your help I couldn’t have done it without you! Now all I have to do is install it. It’s going on the Lackawanna River and is being co-located with the USGS flow monitoring station so that I can use their flow data to correlate with my data. Now working on unit #3!

      Thanks again, all!

Viewing 6 reply threads
  • You must be logged in to reply to this topic.