Welcome to EnviroDIY, a community for do-it-yourself environmental science and monitoring. EnviroDIY is part of WikiWatershed, a web toolkit designed to help citizens, conservation practitioners, municipal decision-makers, researchers, educators, and students advance knowledge and stewardship of fresh water. New to EnviroDIY? Start here

Issues on MMW Site

Home Forums Monitor My Watershed Issues on MMW Site

Viewing 5 reply threads
  • Author
    Posts
    • #15917
      Cheryl Nolan
      Participant

      I’ve been getting sporadic data recording on my MMW site. I’ve noticed several discrepancies in the data. For example I looked first thing this morning and the last displayed/recorded data was yesterday (9/26). I just refreshed the page and the last displayed data has changed to 9/24. Another thing I noticed is that on one line of data there are two different dates in columns A and C. There are also gaps in the data but that, I realize, may have nothing to do with the MMW site. Any ideas as to what may be going on?

      Thanks

    • #15918
      Shannon Hicks
      Moderator

      Your battery is too low.  This is the same issue that was asked about last week:  https://www.envirodiy.org/topic/battery-failing-in-the-middle-of-the-night/

      Anytime your battery voltage drops below 3.55v, the logger won’t transmit, in order to save battery power and conserve enough energy to keep writing the data to the memory card even though it’s not transmitting.  It appears you station is extremely shaded since your battery voltage has been extremely low since June.  Sometimes we see this in stations that have a lot of leaves during the summer, but the issue usually resolves itself in October once the canopy opens up and allows more light.  You could also just buy a second Lipo battery and charger and swap them out a time or two during the summer to keep things at a higher level. You could also try increasing the size of your solar panel, however it’s usually easiest to just swap batteries during the summer, because you should be visiting the site regularly for cleaning or routine maintenance, so you can just swap that battery when you’re there, and also retrieve the data card which will contain any missing data that wasn’t transmitted.

    • #15919
      Cheryl Nolan
      Participant

      Thanks, I turned the solar panel hoping to get more sunlight.

      I’m sorry for the duplication however I did several searches prior to posting but apparently I didn’t include the key words, nothing came up. I didn’t suspect the battery because of the issue with the dates changing from 9/26 to 9/24 on the display on the website as the last data dump and there were two different dates on the same data line (see attached jpegs).

    • #15922
      Shannon Hicks
      Moderator

      The website reports on the last time data was received by the website via the cell modem.  So you’ll have data on the card that’s not on the website.  And there are 2 date/time columns in that data file, one is local time (standard) and one is UTC time.  They are 5 hours off if you’re in the eastern time zone.  So data points in the evening before midnight will have a local time that’s 5 hours behind UTC time, and thus have a date that appears one day behind, but if you look at the timestamp, you’ll see that it’s only 5 hours off.

      I can see that your station started transmitting again about 30 minutes ago.  Adjusting the panel for good sun is important, but you’ll need to replace the battery with a fully-charged one, or this is going to continue.  It’s very hard for the Mayfly to recover from a fully discharged battery by itself while it’s still turned on and operating.  You can either turn it off and leave it for a few days or a week and allow the sun to charge it, or charge another battery elsewhere (either using a spare Mayfly or one of the chargers we recommend in the EnviroDIY manual).

    • #15923
      Cheryl Nolan
      Participant

      Ok, thank you Shannon.

    • #15925
      neilh
      Participant

      Just an observation, once the hardware is working nicely, it often takes more software to manage that hardware 🙂  – it’s a broad subject when talking about power   –  the battery voltage encodes  battery type , solar panel sizing, solar aspect and vegetation  coverage, and when is the power used – all to get the readings to show reliably on the web through all the seasons!!

      I include a “sample number” or sequence number in my recording, so I can easily validate the data (missing sequences) and processor resetting. (sample number goes to zero) . A sample number might help show happens when the dates jump.  Its ProcessorStats_SampleNumber() part of  ProcessorStats()

      I also found in early testing,  I was getting resets at sunset (!) with small batteries, and standardized on using a 4.4Ahr battery. With a good solar aspect on a 2.5W solar panel, it charges in 8hours . Of course winter may not have that good a solar aspect, and typically has less sunshine unless its on the equator !! so I oversize the panel a little if I can, eg 3~5W

      One thing for sure is that if the battery runs down completely, its a software issue on how it powers up  and recharges the battery, one of the challenges in a remote solar powered logger.   The “sample number” does help understand what is going on.

      For my systems, it would take half a day to go and replace with a fully recharged battery (and who pays for all that time)  – I upgraded the software to better manage the voltage. I also use  “reliable delivery” of readings to the web, so when the voltage is low ( I use 3.8V on 4.4Ahr) the rest of the power is reserved for just reading the instruments. This can keep it working during a two week storm with no solar. Then when the sun comes out (and the solar panel hasn’t blow over) the  battery charges back up, and it transmits all the stored readings.  The software is on my fork, (which anybody is welcome to use) and or could be migrated back into the main.

       

Viewing 5 reply threads
  • You must be logged in to reply to this topic.