Welcome to EnviroDIY, a community for do-it-yourself environmental science and monitoring. EnviroDIY is part of WikiWatershed, a web toolkit designed to help citizens, conservation practitioners, municipal decision-makers, researchers, educators, and students advance knowledge and stewardship of fresh water. New to EnviroDIY? Start here

Difficulty connecting to MMW with LTE Adapter

Home Forums Mayfly Data Logger Difficulty connecting to MMW with LTE Adapter

Tagged: 

This topic contains 6 replies, has 3 voices, and was last updated by  Shannon Hicks 1 week, 4 days ago.

  • Author
    Posts
  • #13197

    DaveE
    Participant

    Greetings,

    I am struggling to post data to MMW with a Digi Xbee 3 cell module (https://www.digi.com/products/embedded-systems/cellular-modems/xbee3-cellular-lte-m-nb-iot#partnumbers) and am looking for suggestions.

    I have successfully used the “Logging_to_MMW” to post data with a Xbee WiFi module, but when I switch over to the cell module, I can’t seem to get a connection to the internet for the clock sync.

    –I am using the EnviroDIY LTE Adapter and powering both the cell module and Mayfly with separate 3.7V LiPo Batteries.
    –I have activated a Hologram Sim card and update the APN on line 95 of the “logging_to_MMW” sketch to “apn.konekt.io”.
    –I’m in Salt Lake City, so I’m reasonably confident that there is an AT&T signal.
    –I am aware that there are some nuances related to the order that things are plugged in and powered.
    –Because I am posting data with my wifi module, I’m confident that my UUIDs etc are correct.

    Any suggestions? Aside from the UUIDs and APN, is there something else that needs to be changed in the sketch?

    Many thanks
    Dave Eiriksson

  • #13198

    Shannon Hicks
    Keymaster

    The APN for Hologram is now “hologram” (with a lower case h) so you might try changing your code to that. But I have lots of older modules that have been out for years and still use the old konekt APN (this was Hologram’s old name) so I’m not sure if that’s the issue. Do you have an appropriate LTE antenna connected to the CELL jack (and not the 2.4 jack)?

  • #13199

    DaveE
    Participant

    Thanks for the quick response Shannon,

    I’ll give that APN a try, but it seems more likely that the antenna is the issue. I was under the impression that these modules had built in antennas that would work in areas with high signal strength. Is this incorrect? Do you have antenna suggestions?

    Dave

  • #13200

    Sara Damiano
    Moderator

    Hardware-wise, do you have an antenna attached to the “cellular” uFL connector? You’ll never connect without an antenna.

    But.. these LTE boards are just more finicky than 2G, so…

    You’re using the example from ModularSensors, right? https://github.com/EnviroDIY/ModularSensors/tree/master/examples/logging_to_MMW That example should work with the LTE adapter as written; just change the APN. I usually use “hologram” as the APN, but I think that “apn.konekt.io” works too.

    Have you ever connected this XBee3 or SIM card to the internet before. Occasionally with a new sim card or new module or new location it can take a very, very long time (>20 minutes!) for the module to register. I think Shannon’s been getting most of the new cards to connect within the two minutes the program waits, but I know last week she had a long argument with a few SIMs that took hours of fiddling before registering.

    What versions of ModularSensors and TinyGSM do you have installed? If you’re not running ModularSensors 0.26.16 and TinyGSM 0.9.19, then you should update.

    What output are you getting? Can you paste it in? Are you using PlatformIO or the Arduino IDE? If you’re using PlatformIO, can you add these flags to your platformio.ini flag to turn on some extra debugging printouts and then share the log: (It might be very long.)

    If you can’t get the XBee3 to connect in transparent mode, try switching to bypass. Both Shannon and I have seen it suddenly connect when it’s put into bypass. https://www.envirodiy.org/topic/trouble-registering-with-lte-m-network-on-hologram/ All you have to do to change that example to use bypass instead of transparent is replace the text “DigiXBeeCellularTransparent” in lines 101, 106, and 111 with “DigiXBeeLTEBypass” The library will take care of changing the modes for you. Digi warns all over in their literature that bypass mode is deprecated, but my experience has been that it connects to the network much faster and more consistently when using bypass. I do get occasional freeze ups when using bypass mode that lock everything up until the watchdog reset kicks in (~15 minutes), so once you get it to connect to the network you may want to switch back to transparent for a long term deployment. @aufdenkampe, NeilH and I have some discussion of the different modes here: https://github.com/EnviroDIY/ModularSensors/issues/277

  • #13201

    Sara Damiano
    Moderator

    I don’t think there’s any sort of built-in antenna on the LTE XBee3. I was under the impression that the external antenna is absolutely required. I’ve never gotten it to connect without one.

    We’ve bought ours from Digi Key. I think we’ve tried a couple of different models and haven’t had any problems with any of them. We’ve even put the 2G antennas on and had those work. https://www.digikey.com/products/en/rf-if-and-rfid/rf-antennas/875?FV=93404c3%2C1d6c0003%2Cffe0036b&quantity=0&ColumnSort=0&page=1&k=lte+antenna&pageSize=25&pkeyword=lte+antenna

  • #13202

    DaveE
    Participant

    Thank you very much for your detailed response and suggestions! I’ll get my hands on an antenna and go from there.

  • #13203

    Shannon Hicks
    Keymaster

    There is no built-in antenna on the Xbee LTE module, or any cell module for that matter. I’ve tried a variety of antennas, this is the one we usually use because it’s cheap and fairly rugged and fits easily inside our enclosures: https://www.digikey.com/products/en?keywords=1837-1003

    Just use caution with the u.fl connector, it is not designed for frequent connections and disconnections. You should only connect it once and leave it on.

You must be logged in to reply to this topic.