Welcome to EnviroDIY, a community for do-it-yourself environmental science and monitoring. EnviroDIY is part of WikiWatershed, a web toolkit designed to help citizens, conservation practitioners, municipal decision-makers, researchers, educators, and students advance knowledge and stewardship of fresh water. New to EnviroDIY? Start here

Connecting to Verizon

Home Forums Mayfly Data Logger Connecting to Verizon

Viewing 12 reply threads
  • Author
    Posts
    • #13877
      Matt Barney
      Participant

      Our Mayfly loggers are using XBee3 LTE modems, Hologram SIMs, and ModularSensors 0.23.16. We have one that is having difficulty connecting consistently, and have noticed that on the Hologram dashboard, it always shows it having connected via AT&T Mobility network (similar to the attached screen cap), despite the fact that there is a better Verizon signal at the monitoring site (at least we’re pretty sure there is). Should Hologram display “Verizon” when your XBee connects via Verizon?

      In order to see what Hologram displays for Verizon connections, I’ve tried forcing the modem at my desk to use Verizon by setting CP to 3 (from the default, 0), but it does not want to connect at all. Should this work, assuming I have a Verizon signal?

      Thanks,
      Matt
      cc: @jlemontu-org

      Attachments:
    • #13879
      Sara Damiano
      Moderator

      The Hologram dashboard should say “Verizon” in some way if it connected to that network.  The Hologram SIMs do work on Verizon, but they nearly always connect to AT&T in my experience.  There was a thread just a bit ago about setting the carrier profiles for the LTE-M XBee3’s , and for the time being we’ve decided that the default of “0/Automatic” isn’t stable on Hologram and we will specifically select AT&T unless it’s known to not be present at the site.

      Changing the setting in profile to 3/Verizon should work, but I’ve found you might need to set it and reset or power cycle a few times before the setting “takes.”  You may also need to clear your “forbidden” list:  https://support.hologram.io/hc/en-us/articles/360035697373-How-do-I-clear-the-FPLMN-list-.  From recent conversations with Hologram tech support they say the u-blox SARA R410M is pretty quick to decide that it’s failed to connected to a network/operator and should mark that network as forbidden.

    • #13883
      Matt Barney
      Participant

      Thanks, Sara; I’ll check out the FPLMN issue and keep trying with a modem at my desk.

      What’s the easiest way to send AT commands directly to the modem? Load StreamDebugger on a Mayfly, as described here? https://www.envirodiy.org/topic/trouble-initializing-xbee3-lte-m/#post-12658

      I can’t seem to get any response; i.e., nothing gets echoed to the serial monitor window in PlatformIO.

    • #13885
      Sara Damiano
      Moderator

      Do you have a carrier board that you can use to connect the XBee3 to the computer?  If so, then the easiest way is to use that.

      Open XCTU and find the XBee3.  To type direct AT commands to the u-blox you need to be in bypass – get there by scroll down in XCTU to the “Serial Interfacing” section and change API Enable to “Bypass Mode [5].”  Click the pencil to write.  XCTU is smart enough to reset the Bee when you change the mode.  After changing that, open the terminal tab in XCTU (icon in the top right that looks like a screen with a command prompt on it).  Hit the “open” icon.  Then in the console log section you can type away.  If you don’t get an ok back after hitting enter, verify that you’re in bypass mode.  Try just “AT” several times to make sure you’re talking.  There’s no Digi commands for the forbidden list, so bypass is the only way to do it.

      The StreamDebugger can work, but it’s finickey.  Usually if there’s some reason I want to talk to the XBee directly and I don’t have the carrier board with me, I write the a simple program that wakes the Bee and then sends Serial1.print("AT blah.."); and prints back Serial.print(Serial1.readString()); for everything I want to say and run that on the Mayfly.  Doing it that way usually works better for me.

      If you want to use the Digi AT commands to talk to your Bee, you definitely want to change the “Guard Time” setting either with XCTU or using the Mayfly to send it “ATGT6D3” to increase that guard time back up to the default of 1 second.  To enter command mode you wait the guard time, type in three +++’s (NO ENTER!) and wait the guard time again and should get an OK.  Default is 1s wait on each side.  When TinyGSM talks to the bee, the first thing it does is cut that down to 100ms.  I can’t ever manage to type the +’s in fast enough to get into command mode unless I bump the time up again.  Once you’re in command mode you have 10s from the last successful command before it will automatically fall out of command mode and you’ll need to use the +’s again.  The “ATCN” will also immediately exit command mode.

       

    • #13894
      Matt Barney
      Participant

      Thank you Sara! Using my XBee TH board and XCTU, I got my FPLMN list cleared, and am still trying to force a Verizon connection. Nothing yet, but I will keep trying, power cycling, switching to Bypass and back to transparent, etc.

    • #13897
      Sara Damiano
      Moderator

      If you’re having trouble, you can try going into bypass and checking the operator profile directly on the u-blox:  send AT+UMNOPROF?  It should reply 3 (matching up with the CP value).  If for some weird reason it doesn’t, you can change it by first disconnecting from the network, changing the profile, and then restarting:  AT+CFUN=0 (OK) AT+UMNOPROF=3 (OK) AT+CFUN=1,1 (OK, then a delay and possibly a junk character or two on restart).  The setting should hold when you go back into Transparent (and the Digi software will register the change).

      Shannon and I were just talking about this – the Hologram SIM’s just really prefer AT&T.  Verizon gets written the the FPLMN list really fast.  It appears there as 311480.

    • #13898
      Sara Damiano
      Moderator

      😛  In double checking what the number would be for Verizon when it appears on the FPLMN, the very first google hit I got was an issue with someone else trying to force a Hologram SIM to use Verizon:  https://github.com/botletics/SIM7000-LTE-Shield/issues/163  Per that thread from just a few days ago, others suspect that Verizon has just very recently clamped down again booting out most Hologram users.

      Are you totally sure you can’t just use the weak AT&T signal?  What about T-Mobile?  (As a T-Mobile subscriber, I’m dubious that there’s anywhere that T-Mobile exits and not AT&T.)  You might be able to hop to T-Mobile by using bypass and setting the UMNOPROF to 5.  I haven’t ever tried it and you might be denied by the network, but here’s a chunk of code you can add to your setup that might work:

       

    • #13921
      Matt Barney
      Participant

      I’m unable to query the FPLMN list. I did it successfully last week, so not sure what’s up now.

      When I issue the command, I get 3 errors:

      I thought that the last time I got it to work, I was in bypass mode and airplane mode. This time, I’ve tried bypass and transparent modes and have tried it in airplane mode and in normal mode (AM=0). All return 3 errors. I’m using the Digi TH dev board and XCTU.

      I also get an error (just 1) when I issue

      Thanks for any insights!

      Matt

    • #13922
      Matt Barney
      Participant

      More info: It appears that the command is being sent to the modem at every comma; I had been pasting the entire command into the Console window and getting the 3 errors. If I try typing it by hand, as soon as I type this comma: at+crsm=176,

      …it immediately returns ERROR.

    • #13923
      Sara Damiano
      Moderator

      Huh. I don’t have any *good* suggestions, but he’s a hodgepodge of things to check :

      You have to use bypass or USB direct to be able to use those commands, transparent/command mode won’t work. Can you get normal responses to other commands? (ie AT – OK; ATI – modem info)  Do you have your SIM card installed? The file being cleared is on the SIM card, so it has to be installed. Do you have CFUN set to something other than 0=minimum functionality? At minimum functionality it may not be able to communicate properly with the SIM. Did you try USB direct? With the TH board you can use the side micro USB port for that – keep the USB-c plugged in for power, flip the dip switches by the micro USB both toward the plug, and then use xctu to set device options bit 2 (check the help it might be bit 4 for software usb direct enable) and enable USB direct communication on pin 7 (dio1?).

    • #13950
      Matt Barney
      Participant

      Thanks Sara. I managed to get the forbidden list displayed, and cleared. Not certain what I was doing wrong before.

      If I remain in the Console and continue querying, the forbidden list will get repopulated after 15-30 seconds. The response is:

      So, assuming that that value decodes to MCC=311 and MNO=480, that’s Verizon, and it appears that Verizon just won’t accept the Hologram SIM.

      I’ve ordered a couple of Verizon SIMs from DigiKey, so we’ll see what happens with those. AT&T just won’t work at this particular monitoring site. We haven’t tried T-Mobile, but I assume its coverage is the same as (or less than) AT&T.

      Matt

    • #13951
      Sara Damiano
      Moderator

      Let us know how the Verizon SIMs work for you!

    • #13968
      Matt Barney
      Participant

      The new SIM card from Verizon works! I first did some testing using XCTU, and I can set the Carrier Profile (CP) either to 3-Verizon, or to 0-Auto-detect, and it registers and works successfully. (Not surprisingly, it never registers when CP is set to 2 (AT&T), and I also presume that setting CP=0 in an AT&T-only coverage area would not work).

      Back on the Mayfly, I changed the APN value to ‘vzwinternet’, and it works there too. (The APN value of ‘-‘ will also work; this is the default setting in XCTU.)

      Best,
      Matt

Viewing 12 reply threads

You must be logged in to reply to this topic.