Welcome to EnviroDIY, a community for do-it-yourself environmental science and monitoring. EnviroDIY is part of WikiWatershed, a web toolkit designed to help citizens, conservation practitioners, municipal decision-makers, researchers, educators, and students advance knowledge and stewardship of fresh water. New to EnviroDIY? Start here

Com Ports not connecting to logger

Home Forums Mayfly Data Logger Com Ports not connecting to logger

Viewing 3 reply threads
  • Author
    Posts
    • #15326
      Danielle IWI
      Participant

      I’m working in Arduino and cannot get two of our stations to connect.  Two com ports appear but neither work to connect the logger – the correct board is selected and we tried multiple computers and cables.

      We were able to prepare other stations on each computer so it doesn’t appear to be a driver issue.

    • #15332
      fisherba
      Participant

      If it’s a Windows device each Mayfly will be assigned a different COM port number. Maybe you knew this but that’s the best I have with what you are saying. It’s promising that they connect.

      (I mean, there’s also the is the Mayfly turned on step…)

      • #15379
        Danielle IWI
        Participant

        I did forget that there should be a new port number to the logger, but, yes, it is not assigning a COM port number for two of our loggers.  Is there any reason why some loggers would be able to be assigned a port while others would not?

    • #15374
      JPugh
      Participant

      We found that the USB Serial drivers did not install, this is where we found drivers –> D2XX Drivers – FTDI (ftdichip.com)

       

    • #15381
      Shannon Hicks
      Participant

      Are you using Windows or Mac for connecting to the Mayfly board?  Have you tried more than one USB cable?  Are these two unresponsive Mayfly boards brand new or are they running previously-programmed sketches?  Are there any LEDs that light up when you power the Mayfly board, either from a USB cable or a LiPo battery pack?  Is the small slide switch near the FTDI connector set to the “USB/Lipo” setting and not the “Ext” setting?

Viewing 3 reply threads
  • You must be logged in to reply to this topic.