Welcome to EnviroDIY, a community for do-it-yourself environmental science and monitoring. EnviroDIY is part of WikiWatershed, a web toolkit designed to help citizens, conservation practitioners, municipal decision-makers, researchers, educators, and students advance knowledge and stewardship of fresh water. New to EnviroDIY? Start here

Mayfly Stops Logging and Other Issues

Home Forums Mayfly Data Logger Mayfly Stops Logging and Other Issues

This topic contains 6 replies, has 4 voices, and was last updated by  Drew 3 weeks ago.

  • Author
    Posts
  • #13138

    Drew
    Participant

    Hello,

    I had deployed several Mayfly loggers last week to collect data from a turbidity sensor, and they would log data to the SD card in the lab and for a short time in the field but at some random point they stop logging. Some would log for a few hours while others would log for a few days before stopping. The Mayflys were still running, as we programmed them to flash lights every time they are supposed to collect data, so it isn’t them just switching off as far as we can tell. It also isn’t them running out of space on the SD card, as they are fairly large and the files are small. We missed several storm events already with this issue, but I would like to get them back out soon once this issue is resolved.

    Two of the other loggers we bought have been unusable so far. One does not log to an SD card at all, even though it is the exact same sketch that is on the other Mayflys that have been logging. I have tried several different SD cards, and none have worked. When monitoring the serial monitor when hooked up to this Mayfly, it says it is logging to the SD card but when checking the card, there is nothing there. The other Mayfly does nothing when hooked to my computer, and the bottom of the board near the SJ11 USB Proq location starts heating up, making us think there is a short in this area of the board.

    Any information that could resolve these issues would be greatly appreciated. I added my code snippet below.

  • #13139

    Jim Moore
    Participant

    Drew-
    I can’t offer any specific suggestions for your problems but I recognize some of the code that I used for a similar project to gather Electrical Conductivity (EC) data. I have attached my writeup on this project which includes my code. I have several of these stations deployed and some for almost a year and have not experienced any of the problems that you have had. The only issues I had is with J1:

  • Note: The code uses the D10 hardware interrupt therefor SJ1 must be cut from A7 and connected to D10.
  • Hope this helps
    -jim

  • #13143

    Sara Damiano
    Moderator

    It’s possible that there is a short-circuit in the Mayfly, but this sounds more like a problem with your code or sensors.

    When you’re posting code, please use the “Add Code Snippet” button. It adds coloring and formatting which makes the code much easier to read.

    When you’re troubleshooting the boards, make sure to check the position of all of your switches and jumpers. If the small switch at the top of the board is set to “4-12V” instead of LiPo, the board will not be powered by the computer and thus will not respond when plugged into the computer. Also check all the settings of the jumpers near your Grove ports. Most of then can be changed between 3.3V switched and 5V switched power and the I2C can be changed between 3.3V switched and 3.3V continuous power. Some I2C devices have internal pull-up resistors which can cause the I2C bus to go low if the power is switched off. If the I2C bus is held low for any reason, the Arduino core I2C (Wire) library will crash and the board will completely stop responding. Both the RTC and the auxiliary ADC use I2C to communicate, so the crash might happen when you’re talking to one of them instead of when you’re talking to a sensor.

    I am not familiar with the particular OLED screen you are using, but I wouldn’t recommend any screen for field deployments because they require a fair amount of power. If you do not have one attached, you should probably remove the code for it to help make troubleshooting easier.

  • #13144

    Drew
    Participant

    Hello,

    Thank you for the information. I removed the unnecessary parts in my code, as we currently were not using the OLED screen. Since we are not using the screen any longer, I2C is also no longer being used. All switches on the two boards that were not working as well as the boards in the field are where they need to be, so that is likely not the issue. I also was using the code snippet button, but it posts my code into this exactly like it did above in my original post.

    I tested the twos boards that we had issues with again, and the one that we believe has a short is still acting like it did before, where my computer can tell it is there but cannot upload anything to it and it starts to heat up. The second one that we had a logging issue with appears to be working now, so that has been resolved.

  • #13145

    Sara Damiano
    Moderator

    Since we are not using the screen any longer, I2C is also no longer being used.

    No. If you are using either the DS3231 real time clock or the TI1115 analog-to-digital converter built into the Mayfly, you are using I2C. Both of those are I2C chips.

  • #13146

    Shannon Hicks
    Keymaster

    I edited your original post to put the code into the Code Snippet tool.

    I check every one of the Mayfly boards thoroughly before they get sent out to Amazon, so it’s possible that one with an FTDI or USB jack issue slipped by since that’s the only part of it that I don’t check. Send me an email to mayfly@envirodiy.org and I’ll see what I can do about addressing the overheating board issue.

  • #13157

    Drew
    Participant

    Hello,

    Thank you everyone for your help. These issues have been resolved.

  • You must be logged in to reply to this topic.