Welcome to EnviroDIY, a community for do-it-yourself environmental science and monitoring. EnviroDIY is part of WikiWatershed, a web toolkit designed to help citizens, conservation practitioners, municipal decision-makers, researchers, educators, and students advance knowledge and stewardship of fresh water. New to EnviroDIY? Start here

Errors compiling DRWI_SIM7080LTE.ino code

Home Forums Mayfly Data Logger Errors compiling DRWI_SIM7080LTE.ino code

Viewing 7 reply threads
  • Author
    Posts
    • #16283
      Jim Moore
      Participant

      @damiano – I am attempting to upgrade my LEC stations to the new 4G s

      Simcom boards and I am getting compile errors relating to “NeoSWSerial.cpp”.  I attached a screen shot of the error message. Any suggestions would be appreciated.

      Thanks

       

    • #16289
      Jim Moore
      Participant

      <h2 class=”user-nicename”>@srgdamiano</h2>
      Hi Sara-

      I spelled your handle wrong so maybe you didn’t see this.  Do yo need more details?

    • #16325
      Jim Moore
      Participant

      @srgdamiano @hicks

      Current status of my problem; I am using the 0.5 Mayfly board and have changed to appropite line from 18 to -1 and I get compile errors related to NeosWSerial.ccp.  I have updated all my libraries and still get the same error.

      If I comment out the lib entry for NeoSWSerial the sketch compiles but when loaded the console output appears normal but the simcon board doesn’t come on so I assume the NeoSWSerial is needed and the program doesn’t default to another SWSerial function.

      Help!

       

    • #16327
      Shannon Hicks
      Moderator

      Are you using the new sim7080 directly plugged in to the Mayfly, or are you still using the LTEbee adapter board from your old Digi hardware in between the sim7080 and the Mayfly?

    • #16328
      Jim Moore
      Participant

      The new sim7080 is plugged directly into the Mayfly 0.5b.

    • #16329
      Jim Moore
      Participant

      I assume that the NeoSWSerial function is needed. to talk to the sim7080 and that is why I am not getting any response from the modem

    • #16330
      Shannon Hicks
      Moderator

      Email me your sketch and I’ll load it to a v0. 5b board and see if I can recreate your issue.

    • #16331
      Jim Moore
      Participant

      @shicks

      I emailed the sketch and the associate pio .ini file.

      Thanks for looking into this.

Viewing 7 reply threads
  • You must be logged in to reply to this topic.