Welcome to EnviroDIY, a community for do-it-yourself environmental science and monitoring. EnviroDIY is part of WikiWatershed, an initiative of Stroud Water Research Center designed to help people advance knowledge and stewardship of fresh water.
New to EnviroDIY? Start here

XBee RF / Mayfly Communication Troubleshooting

Home Forums Mayfly Data Logger XBee RF / Mayfly Communication Troubleshooting

Viewing 1 reply thread
  • Author
    • #18177


        A bit frustrating, as this was working last week, but something (hardware or software) seems to have happened.  Regrettably, I do not have git VCS in place for my workflow on this, so can’t say exactly what is was that worked before.  But it wasn’t overly complicated or much different from anything I’m trying now.

        The basic setup is a Mayfly 0.5b with a DH22 temp/humidity sensor wired in and an XBee XB24CZ7WITB003 transmitter in the Bee socket.  Last week, I was able to walk my PC downstairs with the Mayfly upstairs on LiPo power transmitting temperature readings back to the serial terminal on my PC.  Great.

        This week I feel like I’ve tried everything but can’t get an XBee signal from the Mayfly doing the same.  In trying different things, I can still get my two XBee transmitters to communicate via USB breakout boards, including from one on one PC to one on another.  So that tells me the config on the two XBees is at least nominally correctly configured for communication.  But this week, whenever I put the Router/Endnode (alternately configured) in to the Mayfly, nothing transmits via Serial1.

        Very basic sketch from another thread:

        Then with the Mayfly plugged into a PC via USB, I can get serial messages at 57600 over USB.  But my XBee coordinator reads nothing at 9600.  Then, if I pull the XBee from the Mayfly and remount it on a USB breakout connected to a PC I can run:

        and then type messages that get transmitted to my coordinator node.  Almost suggesting a hardware issue with the Mayfly.

        I’ve checked and I’m mounting the XBee in the correct alignment with all the pins seated… Any suggestions as to what the problem may be, or how to troubleshoot further?



      • #18178
        Shannon Hicks

          It’s been a while since we’ve used Xbee modules with our Mayfly boards, so I don’t remember all the tricks to configuring the routers and coordinators, but your Mayfly code looks correct to me.  Have you tried removing the wake and sleep commands and just leave the Xbee module constantly powered to see if that helps?  Are you using the Mayfly v.05b board for all your tests?  There were some significant design changes when we migrated to the v1.0 board, some of which affect how the Mayfly’s Xbee socket behaves.

      Viewing 1 reply thread
      • You must be logged in to reply to this topic.