Welcome to EnviroDIY, a community for do-it-yourself environmental science and monitoring. EnviroDIY is part of WikiWatershed, a web toolkit designed to help citizens, conservation practitioners, municipal decision-makers, researchers, educators, and students advance knowledge and stewardship of fresh water. New to EnviroDIY? Start here

Problem with Arduino IDE loading Mayfly board data from github website

Home Forums Mayfly Data Logger Problem with Arduino IDE loading Mayfly board data from github website

Viewing 3 reply threads
  • Author
    Posts
    • #1743
      Marion
      Participant

      I am running Windows 10 running 64 bit. The Arduino IDE downloads, installs and starts up. However, when I plug the Mayfly into a USB port and then go to the IDE Board Manager to select the board under “Contributed”, it does not appear and at the bottom of the IDE screen the error message appears: “error downloading: https://raw.githubusercontent———–” I have triple checked to see that my spelling of the file location is exactly as posted on this website under software installation instructions. If this is a Windows 10 64 bit issue, I have access to a computer running Windows XP. However it does not have Internet access, so I would have to download the file on a data stick and transfer it to that machine in the proper folder.

      Can anyone help on this?

    • #1745
      Paul Dyer
      Participant

      Marion

      I had a similar problem. I assume you are using Arduino IDE 1.6.12, the latest version on the Arduino website. Even though the Getting Started With Mayfly says you can use Arduino IDE 1.6.5 or newer, the current version (1.6.12) does not seem to correctly support the Mayfly. I corrected my problems by downloading and using IDE 1.6.5. Give this a try and let me know if it works for you.

      Regards

      Paul

    • #1746
      Shannon Hicks
      Keymaster

      This is interesting, thanks for the information Paul. I haven’t encountered this problem with any of the recent Aruino IDE builds as of a few months ago, but I’ll try it with the latest one and see if I can resolve the issue.

      • #1749
        Marion
        Participant

        As suggested by Paul, once I had loaded IDE version 1.6.5 the communication problem was resolved. I was able to complete the installation and start up the Mayfly without any other issues.

        Thanks

    • #1757
      Shannon Hicks
      Keymaster

      After extensive testing with 8 of the latest versions of the IDE, I can confirm that the EnviroDIY board configuration file that is currently posted on Github will work with Arduino IDE versions 1.6.5 through 1.6.12.

      There was an update done to the IDE starting with version 1.6.11 that caused an incompatibility with the Mayfly configuration file on GitHub. But I just updated that config file and tested it with version 1.6.11 and 1.6.12, and everything is working fine now. Thanks for pointing out the issue, Paul and Marion.

Viewing 3 reply threads
  • You must be logged in to reply to this topic.