Welcome to EnviroDIY, a community for do-it-yourself environmental science and monitoring. EnviroDIY is part of WikiWatershed, an initiative of Stroud Water Research Center designed to help people advance knowledge and stewardship of fresh water.
New to EnviroDIY? Start here

Issue w/ mac communicating w/ v0.5b board

Home Forums Mayfly Data Logger Issue w/ mac communicating w/ v0.5b board

Viewing 3 reply threads
  • Author
    • #18434

        Hello, I have been trying to connect to a board to get a sketch loaded on but the Arduino IDE is not communicating with the board. The errors I have received are:

        • avrdude: stk500_recv(): programmer is not responding
          avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00

        I have followed this thread to try and trouble shoot the issue: https://www.envirodiy.org/topic/pc-and-mac-unable-to-communicate-with-mayfly-ver-0-5b/

        Things I have tried:

        • update the drivers
        • test different cables
        • test different computers
        • test in a Windows VM

        I can confirm that my mac is recognizing the board (see screenshots)

        Things I have not tried:

        • Adafruit CP2104 Friend

        I would appreciate any advice on things to try next!

        Thank you!

      • #18439

          Update: I removed the SD card and everything started to work fine. That doesn’t really explain the problem though so would love it if someone has any ideas what was going wrong.

        • #18440
          Shannon Hicks

            Have you tried a different microSD card?  Either it’s a defective card or sometimes one or more of the pins in the microSD card socket can get damaged when inserting a card and cause a short-circuit inside the socket that prevents the Mayfly from operating properly.  Are you using the onboard microSD socket on the Mayfly board, or the optional vertical microSD card board plugged into the 2×4 header next to the power switch?

          • #18443

              I was actually having trouble with both. It is now working with the onboard socket.

          Viewing 3 reply threads
          • You must be logged in to reply to this topic.