Welcome to EnviroDIY, a community for do-it-yourself environmental science and monitoring. EnviroDIY is part of WikiWatershed, a web toolkit designed to help citizens, conservation practitioners, municipal decision-makers, researchers, educators, and students advance knowledge and stewardship of fresh water. New to EnviroDIY? Start here

Innacurate LiPo battery voltage data

Home Forums Mayfly Data Logger Innacurate LiPo battery voltage data

Viewing 3 reply threads
  • Author
    Posts
    • #13445
      Steve Ochs
      Participant

      This will probably be a question for Shannon since it is hardware related but I have a Mayfly 0.5b I purchased earlier this year and it started sending data showing a low LiPo battery voltage (3.4v instead of 3.9v). This board has only been used for software development but I was getting ready to deploy it.
      I verified the battery is indeed 3.9v.
      Thinking it was an A/D issue, I checked the voltages at the voltage divider circuit and it was indeed only 3.4v.
      Tracing it back in the circuit I have found the input V_BATT (drain) terminal on FDN340P MOSFET to be 3.9v but the output (source) terminal of the MOSFET to the voltage regulator is only 3.4v. The gate is 3.5v
      I then checked another Mayfly and the difference between the drain and source are within 0.06v (negligible)
      Bad Good
      Gate 3.5v 2.7v
      Drain 3.9v 3.9v
      Source 3.4v 3.9v
      See attached markup of Mayfly drawing for voltages measured.
      Is it possible the MOSFET is bad or possibly D3?
      I hate to throw a fairly new board away just for this if I can fix it.
      Thanks

      Attachments:
    • #13447
      Shannon Hicks
      Keymaster

      Yes, this is a known issue that I’ve seen with only a very few boards recently where we see those exact same incorrect voltage readings around the Q1 mosfet. I haven’t tried replacing parts to see whether it’s the mosfet or the D3 diode, but it’s definitely either one of those, or possibly both of them. I’ll see if I can experiment with some bad board this weekend and find the culprit. I’ve never been able to purposely cause a failure even though I’ve tried really hard to repeat the conditions and stress out the components with various hardware and power configurations. Were you powering the board from the microUSB port, the FTDI header, a LiPo battery, or a combination of those? And did you have any telemetry (radio, wifi, cellular) xbee modules installed at the time?

    • #13449
      Steve Ochs
      Participant

      I had the board powered with the 2500 mah LiPo battery and a 2w Voltaic solar panel and I was monitoring battery life when I saw the sudden drop in voltage.
      I am using a XBEE S6B wifi module for telemetery.
      Current draw on the battery is between 100ma and 120ma when reading sensors and transmitting
      Current draw is not measurable when sleeping
      Sampling interval is 15 minutes
      I can’t quite make out the serial number but it appears to be 19-0025
      Thanks, Steve

    • #13450
      Shannon Hicks
      Keymaster

      Thanks for the additional information, I appreciate you helping us out with this. I’ll send you a PM about what to do next.

Viewing 3 reply threads

You must be logged in to reply to this topic.