Welcome to EnviroDIY, a community for do-it-yourself environmental science and monitoring. EnviroDIY is part of WikiWatershed, a web toolkit designed to help citizens, conservation practitioners, municipal decision-makers, researchers, educators, and students advance knowledge and stewardship of fresh water. New to EnviroDIY? Start here

Reply To: Hydros CTD-10 Regularly Dropping Out (-9999)

Home Forums Environmental Sensors Hydros CTD-10 Regularly Dropping Out (-9999) Reply To: Hydros CTD-10 Regularly Dropping Out (-9999)

#16651
SGFulton
Participant

Hi James, we regularly had this problem when using the Decagon CTD-10s connected to a DIY Arduino Mega data logger. We ended up taking the median value of 10 measurements taken 1x/second every 5 mins. However, what eventually worked (if I’m remembering this correctly; this was my dissertation research done in 2016-2019) was clamping an RF ferrite balun filter to the cables. They looked something like this: https://www.digikey.com/en/products/detail/fair-rite-products-corp./0444173951/8594098?utm_adgroup=Ferrite%20Cores%20-%20Cables%20and%20Wiring&utm_source=google&utm_medium=cpc&utm_campaign=Shopping_Product_Filters_NEW&utm_term=&utm_content=Ferrite%20Cores%20-%20Cables%20and%20Wiring&gclid=CjwKCAiApfeQBhAUEiwA7K_UH7XcVuubBeU3WlGAQFSizFtYSRyiAbgXnIgNb0TLWobKsUVKiNRBVxoCfTAQAvD_BwE

I think it must’ve been noise interference from somewhere on our board. Hope this helps! I have code you’re welcome too if you’re interested.

Stephanie