Welcome to EnviroDIY, a community for do-it-yourself environmental science and monitoring. EnviroDIY is part of WikiWatershed, an initiative of Stroud Water Research Center designed to help people advance knowledge and stewardship of fresh water.
New to EnviroDIY? Start here

Activity

  • scornia replied to the topic Logging Mayfly with Decagon SDI-12 Sensor in the forum Mayfly Data Logger 3 years, 10 months ago

    Hi Sara,

    I am having issues when I come to this step and can use a little help troubleshooting my issue. I cannot get my sensor to connect to an address. I have an SDI-12 sensor with bare wires connected to grove 4-pin terminal adapter set up just as you explained in the instructions. All of the connections seem secure, but when I run the b_address_change sketch, it continuously runs through every slot saying “vacant” and gives the message “No sensor connected. Check physical connection.”

    I am not sure what the issue could be and was wondering if you may have any ideas.

    Thanks,

    Steve

     

    • scornia,
      In May I had this exact setup deployed and working. I used a WiFi modem and was logging to MMW. It slowly lost power because it was in too much shade and eventually I replaced it with a U-20 level logger. Now I’m working on this setup again and I’m having a similar issue to yours; the address change sketch just loops and my serial monitor returns -9999 for temp., cond, and depth. I don’t remember exactly what I did to get it working last time but I’m pretty sure I got the address changed to “1”, so I think I’m going to focus on that to get the readings to show up again. Let me know if you figure it out.

      Best Regards